---
title: Parquet Parser
slug: connectors/parquet-parser
docTags: 
createdAt: 2026-06-09T16:30:12.323Z
---

The Parquet Parser provides automated extraction and processing of data from Apache Parquet files for streamlined analysis.

Parquet is a popular open-source columnar storage file format widely used for efficient data storage and retrieval, especially in big data and analytics workflows. The Parquet Parser connector enables Swimlane Turbine users to automatically parse and extract data from uploaded Parquet files within their security automation playbooks. By integrating Parquet file parsing directly into Turbine, users can seamlessly ingest, analyze, and operationalize structured data from diverse sources without manual intervention or custom code. This streamlines data-driven security workflows, enhances automation capabilities, and accelerates incident response by making complex data immediately actionable.

This connector reads in a Parquet file and converts it into a JSON object, which can then be ingested by downstream applications.

## Metadata

Sample metadata returned:

```javascript
"metadata": {
    "num_rows": 156,
    "num_columns": 20,
    "column_names": [
        "metadata",
        "cloud",
        "src_endpoint",
        "dst_endpoint",
        "connection_info",
        "traffic",
        "time",
        "start_time",
        "end_time",
        "severity_id",
        "severity",
        "class_name",
        "class_uid",
        "category_name",
        "category_uid",
        "activity_name",
        "activity_id",
        "type_uid",
        "type_name",
        "unmapped"
    ],
    "column_types": {
        "metadata": "object",
        "cloud": "object",
        "src_endpoint": "object",
        "dst_endpoint": "object",
        "connection_info": "object",
        "traffic": "object",
        "time": "int64",
        "start_time": "int64",
        "end_time": "int64",
        "severity_id": "int32",
        "severity": "object",
        "class_name": "object",
        "class_uid": "int32",
        "category_name": "object",
        "category_uid": "int32",
        "activity_name": "object",
        "activity_id": "int32",
        "type_uid": "int32",
        "type_name": "object",
        "unmapped": "object"
    },
    "memory_usage": 279461,
    "describe": {
        "time": [
            156.0,
            1678822323576.923,
            92110.1751558733,
            1678822108000.0,
            1678822249500.0,
            1678822323000.0,
            1678822398750.0,
            1678822494000.0
        ],
        "start_time": [
            156.0,
            1678822323576.923,
            92110.1751558733,
            1678822108000.0,
            1678822249500.0,
            1678822323000.0,
            1678822398750.0,
            1678822494000.0
        ],
        "end_time": [
            156.0,
            1678822342006.4102,
            91207.1372981708,
            1678822139000.0,
            1678822270750.0,
            1678822335000.0,
            1678822420000.0,
            1678822503000.0
        ],
        "severity_id": [
            156.0,
            -1.0,
            0.0,
            -1.0,
            -1.0,
            -1.0,
            -1.0,
            -1.0
        ],
        "class_uid": [
            156.0,
            4001.0,
            0.0,
            4001.0,
            4001.0,
            4001.0,
            4001.0,
            4001.0
        ],
        "category_uid": [
            156.0,
            4.0,
            0.0,
            4.0,
            4.0,
            4.0,
            4.0,
            4.0
        ],
        "activity_id": [
            156.0,
            0.5064102564102564,
            0.5015690847060224,
            0.0,
            0.0,
            1.0,
            1.0,
            1.0
        ],
        "type_uid": [
            156.0,
            400100.50641025644,
            0.5015690847060224,
            400100.0,
            400100.0,
            400101.0,
            400101.0,
            400101.0
        ]
    }
},
```

# Actions

## Parse Parquet

Parse an uploaded Parquet file from attachments and extract its data for further processing or analysis.

### Endpoint

- **Method:** `GET`

### Input

| **Argument Name**       | **Type** | **Required** | **Description**             |
| ----------------------- | -------- | ------------ | --------------------------- |
| `metadata`              | boolean  | Optional     | Include Metadata            |
| `attachments`           | array    | Required     | File to be analysed         |
| `attachments.file`      | string   | Optional     | Parameter for Parse Parquet |
| `attachments.file_name` | string   | Optional     | Name of the resource        |

### Input Example

`{"metadata":true,"attachments":[{"file":"string","file_name":"Example Name"}]}`

### Output

| **Parameter**                           | **Type** | **Description** |
| --------------------------------------- | -------- | --------------- |
| `metadata`                              | object   | Response data   |
| `metadata.num_rows`                     | number   | Response data   |
| `metadata.num_columns`                  | number   | Response data   |
| `metadata.column_names`                 | array    | Response data   |
| `metadata.column_types`                 | object   | Response data   |
| `metadata.column_types.metadata`        | string   | Response data   |
| `metadata.column_types.cloud`           | string   | Response data   |
| `metadata.column_types.src_endpoint`    | string   | Response data   |
| `metadata.column_types.dst_endpoint`    | string   | Response data   |
| `metadata.column_types.connection_info` | string   | Response data   |
| `metadata.column_types.traffic`         | string   | Response data   |
| `metadata.column_types.time`            | string   | Response data   |
| `metadata.column_types.start_time`      | string   | Response data   |
| `metadata.column_types.end_time`        | string   | Response data   |
| `metadata.column_types.severity_id`     | string   | Response data   |
| `metadata.column_types.severity`        | string   | Response data   |
| `metadata.column_types.class_name`      | string   | Response data   |
| `metadata.column_types.class_uid`       | string   | Response data   |
| `metadata.column_types.category_name`   | string   | Response data   |
| `metadata.column_types.category_uid`    | string   | Response data   |
| `metadata.column_types.activity_name`   | string   | Response data   |
| `metadata.column_types.activity_id`     | string   | Response data   |
| `metadata.column_types.type_uid`        | string   | Response data   |
| `metadata.column_types.type_name`       | string   | Response data   |
| `metadata.column_types.unmapped`        | string   | Response data   |

### Output Example

`{"metadata":{"num_rows":156,"num_columns":20,"column_names":["metadata","cloud","src_endpoint"],"column_types":{"metadata":"object","cloud":"object","src_endpoint":"object","dst_endpoint":"object","connection_info":"object","traffic":"object","time":"int64","start_time":"int64","end_time":"int64","severity_id":"int32","severity":"object","class_name":"object","class_uid":"int32","category_name":"object","category_uid":"int32"},"memory_usage":279461,"describe":{"time":[],"start_time":[],"end_time...`

# Response Headers

| **Header**   | **Description**                                       | **Example**                   |
| ------------ | ----------------------------------------------------- | ----------------------------- |
| Content-Type | The media type of the resource                        | application/json              |
| Date         | The date and time at which the message was originated | Thu, 01 Jan 2024 00:00:00 GMT |
